As off April 29th, 2020, PRISMA will stop supporting TLS versions 1.0 and 1.1 - which are no longer considered sufficiently secure - and will instead use the latest version, TLS 1.2.

To be prepared for this, please check if your browser of choice is compatible with this new version. If it isn’t, you may have trouble accessing the platform.
To check for compatibility, click here or here for a list of browsers that support TLS 1.2.


If you're using an older version of Internet Explorer, follow the steps below:


a. Go to Tools and select Internet Options;


b.Select the Advanced tab in Internet Options;

c.Enable (check) TLS 1.2 and also disable (uncheck) SSL 3.0 for additional security;

d. Click on Apply and OK to complete the procedure.